[Let's Play] NetHack 3.6.1

Afterburner

Remarkably expressive bandages
RPGnet Member
Validated User
AND SO IT CAME TO PASS that I found myself re-reading KoboldLord's old Let's Play SporkHack thread.

AND LO did it rekindle my interest in NetHack. Which pretty much catches us all up on relevant current events.

If you have never read that thread, and if you like NetHack and its variants, that thread is a masterpiece. KoboldLord's mastery of both the game mechanics and the craft of writing an engaging "Let's Play" thread are on full display there. Even if the thread is nearly 10 years old at this point, and even if the game mechanics have moved on to some degree, there is still a wealth of information to be had about the game in that thread.

The thread is so useful, in fact, that it (along with the NetHack wiki) helped me to reach my first ascension (chronicled in the later bits of the thread) roughly two weeks after I started play.

As it happens, that was also my last ascension, because my interests are mercurial and my attention span is brief, and I haven't touched NetHack at all since my final posts in that thread some 9 years ago.

<dramatic movie trailer voiceover>
UNTIL NOW...
</dramatic movie trailer voiceover>

Since that time, vanilla NetHack has been updated. The last time I played, it was version 3.4.3, which had (at the time) been the official version of NetHack for seven years or so, and would go on to be the only official version for another five. But in 2015, the DevTeam released NetHack 3.6.0, the first major update in 12 years. And now we're up to version 3.6.1. So off I go to try and ascend once again and maybe we'll run into some of the more interesting changes they have implemented in the most recent versions.





Direct. To the point. I like it.

I should point out, btw, that I am NOT a master of the game like KoboldLord. Realistically, my sum total of NetHack experience covers about three weeks. And that was 9 years ago. So I don't expect this to be easy.

I will at least try to make my inevitable deaths entertaining.




I find the concept of a Cavegnome to be hilarious. Nasty, brutish, and short. My last attempts to ascend were with a Cavegnome named Tharg, and that's what we'll stick with now.




Hopefully the goddess Ishtar will guide our steps!




...and, okay. Confession time. The game recounted here in this post is not actually my first game in 9 years. There have been a few others over the past few days to help me regain some very basic mechanical knowledge of how to play the game. When you haven't even touched a particular game in 9 years, you forget (or at least I had forgotten) most of the barest rudiments of how to even play at all. Didn't remember most of the commands, didn't remember how to buy or sell things in shops, and so on. Lots of very basic knowledge that I needed to re-learn. So there were a few exploratory games without any purpose other than remembering "How do I do X again?"

During my ascension run a decade ago, I used the Vulture's Eye 3D interface that makes the game look kinda Diablo-esque. The gameplay isn't any different to the standard ASCII interface, but the game view is an isometric 3D view. I was ridiculed by Matt Colville for my rank heresy.

(The Vulture's Eye version is still available, btw, but has been renamed simply "Vulture" and is available on Steam for a paltry $3. If you have been mildly curious about NetHack before but have been put off by the ASCII interface, Vulture might be right up your alley.)

Anyhow, I didn't want to use Vulture this go around. I wanted to be traditional. I wanted to get the full ASCII "old Unix grognard" experience. Problem is: I'm 51 years old now, and these old eyes ain't what they used to be. Gleaning information from the ASCII interface is not easy when you have to squint. So as much as I would like to play the game in full ASCII mode, I'm going to have to use the graphical UI client they made for Windows.




Uh...



That's...not an improvement. It is possibly even worse.

But oh, hey, there's this command here:





And...oof. Nope. Not helping.

Hrm.

<sounds of internet being consulted>

Ah-hah!

<mechanical sounds of tools being used to tinker with something>

<ratchet noises>

<mild clanging>

<silence>



THERE we go. MUCH better.

This is the "NetHack Modern" tileset for the Windows GUI client. Comes in four different tile sizes: 32x32, 48x48, 64x64, and 96x96. The version I'm using is the 48x48 tileset.

This is not a different program. This is the standard "NetHackW.exe" program that comes with the zip file you download from nethack.org. But it is possible to use a different set of graphics by frobnosticating very mildly with the defaults.nh file.

N.B.: I have also edited the corridor tiles to give them an actual color. The default tileset simply uses white circles/dots on black tiles for corridors, so the final result makes the corridors look like floating circles in space. I like my corridors to feel more corridory, so I did some very basic color editing in GIMP for those tiles.



Now that "Fit To Screen" function has a use: Letting us see the entire map when we need to. We can even play the whole game like this, but I prefer the up-close view. I'll switch to the full map view as necessary.
 
Last edited:

Afterburner

Remarkably expressive bandages
RPGnet Member
Validated User


The starting equipment for a Cavegnome isn't very impressive.

Cavegnomes can reach Expert level in both Club and Sling. But on the other hand there aren't any nice high level clubs or slings in the game, so bumping them up to Expert is kind of a waste of skill points. On the gripping hand, my prior experience (all three weeks of it) suggests that there comes a point where you will want to have SOME kind of weapon skill at "Skilled", even if you "waste" a skill point by doing so, because otherwise you will die in combat. And dead characters don't improve their skills with ANY weapons.

The Cavegnome quest artifact is a Mace, and Cavegnomes can also get Maces up to Expert level, so under ideal circumstances we will find a mace early on in the game and we won't have to waste skill points on the club. Maces are rare, so it's not likely, but hope springs eternal.

Despite all logic and reason, Tharg will try to get his Sling skill up to Expert so that he can mow people down with rocks. Fortunately, he's pretty beefy. His current carrying capacity is 850. The rocks combined weigh 460. Over half his carrying capacity is committed to carrying sling ammo. This is what you get when you have INT 11 and WIS 9. A smarter character would drop all that stuff in favor of lightweight darts or something. But not Tharg.

Tharg is also as ugly as the northern end of a southbound hippo. Succubi will not have much use for him, and merchants will fleece him on shop prices.




I don't recall knowing about this trick in my last playthrough. If you're absolutely certain that there's a secret door in a wall somewhere, you can (k)ick it and the door will reveal itself. It will also (according to the NetHack wiki) exercise your DEX, so this can help you raise that ability.

On the other hand, if you're wrong about there being a secret door in the wall at a particular location...



Wounded leg and DEX damage. Fortunately, the DEX damage wasn't permanent, and in a few turns Tharg's leg was as good as new.




Tharg appreciates the timely arrival of the salad bar.




Well, that seems to do it for DLVL 1. There might be another room hidden down there somewhere, but Tharg doesn't have the tools yet to try and find them. We're not getting any "You hear someone cursing shoplifters" or "You hear the footsteps of a guard on patrol" messages, so even if there IS another room down there in the inky blackness, it'll just be a plain ol' regular room.

I am anal retentive enough that if I should find myself with an excess of Magic Mapping scrolls (or, even better, the spell itself memorized and castable), I'll come back up here just to see. But otherwise, not much reason to worry about it. On to DLVL 2!




Tharg found a fountain and a ring in this room. Slasher the Dog BUC-tested the ring and found it wanting, so in the pouch it goes for now.

Tharg is going to wait until he's a little more powerful to start messing around with the fountains and the sinks. The sink icon in this tileset is identical to the fountain icon you see here, except that it's a lighter shade of blue.




Tharg has been hearing sounds of a cash register, but as far as he can tell, this level of the dungeon has been fully explored. Time to go on a Secret Door Hunt...




Ah-hah! A potion shop! Time to categorize some potions!

Now, I can't specifically ID any of these potions. But I can certainly sort them into broad categories. Potions of booze, fruit juice, see invisible, and sickness (for example) all have the same price. So even though I can't determine which potion is specifically a potion of see invisible, I can determine the four potions that could potentially be a potion of see invisible.

I locked Slasher out of the shop so he wouldn't mess up my research. Maybe later Tharg will bring Slasher down here and see what he can steal.




Got this message randomly. No clue why. Consulting the wiki, it seems that the only thing Tharg might have done which might exercise CON is being "not hungry" on a turn ending with "0". Except that this turn didn't end with "0". So I dunno.

Still, Tharg is grateful for the additional CON.




Nice, a co-aligned altar right here on DLVL 3. This will come in handy later.

Apparently this altar was crafted between September 23rd and October 23rd.
 
Last edited:

Afterburner

Remarkably expressive bandages
RPGnet Member
Validated User


According to the NetHack wiki, this inscription on the floor can mean only one thing:



There is a vault entrance here.

And sure enough, there was. I stepped in to the little closet and found myself teleported to a 2x2 room with piles of gold...and no way out.

This falls into the category of "Things I used to know but have forgotten". I distinctly recall looting vaults during my last playthrough 9 years ago, but I didn't remember details. So I jumped right in and found myself trapped.

Fortunately, a handy guard showed up. He demanded to know who I was. I told him "Croesus", because according to the wiki, this will get him to leave you alone. And it worked! He left me alone! And also left me no way out of the vault.

Boogers.

Fortunately, he eventually came back. So this time I didn't give him the name "Croesus".



I did as instructed and dropped the gold. I'll come back for it later, once I've acquired a suitable way out of the vault.




Long way away from the vault entrance. Gonna hafta make it all the way back across the dungeon to rejoin Slasher.




Or perhaps not.

This was the moment where I looked at the screen, saw that I was dead, and said to myself "Oh yeah, I shoulda etched an Elbereth here!" These are the little details one forgets in 9 years.

Anyhow, possessions identified:




Tharg's final attributes:




A new feature added to v3.6.0, accessible in the game with the #overview command, but also available when you die (and presumably when you ascend):






Alas poor Tharg, we barely knew ye. What mighty deeds could you have achieved if not felled by my dim memory of how to play this game?



Fortunately, Tharg, Son of Tharg may be able to answer that question...
 

Bicorn

Active member
Validated User
Got this message randomly. No clue why. Consulting the wiki, it seems that the only thing Tharg might have done which might exercise CON is being "not hungry" on a turn ending with "0". Except that this turn didn't end with "0". So I dunno.
Attribute increases don't occur the moment the attribute is exercised. It gets invisibly marked as exercised (or abused, depending) then at some later point the game tests whether to change it.
 

KoboldLord

Registered User
Validated User
Good luck, and I want to warn you that the newest Nethack is a whole bunch harder than the versions I played. Elbereth got nerfed HARD, and although they dialed it back the nerf partway in the most recent patch, it is still quite substantially less reliable than it was when I did my thread. They did not change the monster spawn list as far as I can tell, so the early game is much more dangerous without a reliable way to ward off certain monsters that have no business showing up as early as they can. Soldier ant swarms, for instance.
 

Afterburner

Remarkably expressive bandages
RPGnet Member
Validated User
Good luck, and I want to warn you that the newest Nethack is a whole bunch harder than the versions I played. Elbereth got nerfed HARD, and although they dialed it back the nerf partway in the most recent patch, it is still quite substantially less reliable than it was when I did my thread.
Not to worry! As you can already see, I forget to use the damn thing in any event, so I likely won't notice the change!

Also of minor interest to me: I notice above, in Tharg's final attributes, the phrase "...nominally on a mission for Ishtar". I have never seen "nominally" used there. Any idea what that represents?
 

anowack

Member
RPGnet Member
Validated User
I'll be watching this with interest, much like I watched KoboldLord's thread. I've never had the commitment to get any more competent than the dabbler's "play a bit and die on a single-digit level" at any of the classic rougelikes, but I've always been fascinated by them.

(Also, the SporkHack thread being ten years old makes me feel old.)
 

Afterburner

Remarkably expressive bandages
RPGnet Member
Validated User
Once again, the continuing adventures of Tharg Thargson.



A hobbit dropped this surprisingly nifty cloak on DLVL 1, which is a nice pick up so early in the game. The wiki informs me that this is an Oilskin Cloak, which has many nice properties. It will keep my stuff dry and also provides Magic Cancellation. Also decent AC.



Given Tharg's abysmally low CHA (lower even than his old man), he would probably only frighten himself by looking in this mirror. Or possibly crack the mirror outright.




Speaking of low CHA, Tharg's CHA of 5 ensures that he will have to pay the maximum possible price for any goods he wishes to purchase.

He paid close attention to the shopkeeper's discussion of shoplifting, hoping to pick up some useful tips for later when he returns to steal stuff.

Also: I'm not 100% sure, but I think the color of all the icons in this tileset map to the color of those monsters or objects in the ASCII version. That is, the yellow potion shown here would be a yellow "!" in the ASCII version, the green gem here would be a green...whatever the ASCII character is for a gemstone, etc.

So on some level I am getting SORTA the ASCII grognard experience! Plus, dig that phat @.




Hobbits are represented by meeples. I am amused.




Another hobbit dropped this elven mithril-coat, which is pretty snazzy. Only on DLVL 2 and Tharg's AC is pretty respectable for his level and where he's at in the dungeon.




Bah. I find this annoying. I feel like I should be allowed to be "Satiated" without it abusing my DEX if I can manage to find enough food.




One of Tharg's kinsmen! This is what Tharg would look like if Tharg weren't a PC.

Slasher is eyeing the gnome with gustatory intent, so I will do my kinsman a favor and leave.




I like how the mimics actually stand out like a sore thumb in shops. Especially in this tileset, but also in ASCII. Completely negates their ability to disguise themselves.

I did pick up the key for 20zm, and will come back later for the pick axe if I can't find one in the interrim.




Dammit, another DEX hit. I don't recall exeperiencing so many attribute drops in my last ascension run. But my last ascension run was 9 years ago and I've slept since then. So I may just not remember.




Welp, this is it. No more doors or corridors anywhere to be seen. The Dungeons of Doom were clearly only partially constructed. The contractors got as far as this room and this corridor on DLVL 4 and then refused to do any further work until Rodney paid them the backpay he owed them.

Shame about the Amulet of Yendor and the whole quest for Ishtar thing. Maybe Tharg will come back in a year or two when the contractors have had more time to excavate further down.
 

Afterburner

Remarkably expressive bandages
RPGnet Member
Validated User


Just as he was leaving, he stumbled on a rock (due to his ever-lowering DEX) and bashed his forehead against the wall. And it made a hollow sound.

The wall, not his forehead.

Some poking and prodding revealed a hidden wash room with a hole in the middle to serve as a drain.




Boy, DLVL 4 is small! Only two rooms, total! But at least we have a set of stairs going down, so we can continue our journey.

But just in case, Tharg is going to check for more secret doors. Hopefully his forehead can survive.




It took Tharg FRO EVAR to find this last secret door. Believe me when I tell you that he has been around this room several times, performing close inspection on every section of wall. "n20s" was his best friend during his search. Took over 400 turns to finally find another way out to the rest of the level.




Things got a little dicey here. Tharg was basically running circles around Slasher so that Slasher could attack the pony every turn. Eventually Slasher prevailed.




This is a different pony, one that is currently peaceful to Tharg. Slasher has not yet seen fit to engage him in combat.

Also, it seems that banging his head against all those walls looking for a hidden door managed to knock a small amount of sense into Tharg.




And here we have the Gnomish Mines. It's very cavelike down here. Tharg feels quite at home.




Fortunately, it is well-lit. Tharg's fellow gnomes are performing routine maintenance on the wall torches.

It is well-lit enough that Tharg can see a few nasties heading his way, as well as some additional treasure.






Well combat is going swimmingly so far. Tharg waits to see if the hobbit will kill any other local monsters.

(He didn't. Tharg had to kill the hobgoblin and the hobbit himself.)




Tharg wasn't planning on exploring the Gnomish Mines. He still hadn't found an altar yet, nor had he found any bags or sacks. So he was going to try for Sokoban first before going further down in the mines.

Then Slasher stumbled across a teleport trap, and now Tharg has to go find him. So it looks like he'll be exploring at least this level of the Gnomish Mines.
 

Afterburner

Remarkably expressive bandages
RPGnet Member
Validated User


Ah-hah! There he is! Good boy! Try to avoid any more teleportation traps.

There are a set of stairs going down here, but we're not going to explore any deeper into the mines just yet. We will, however, complete our exploration of this level to satisfy our anal-retentive nature.




CRAP.

Tharg had been using his sling to fire flint stones, see? He's been slinging 'em all over the place. Sometimes they break on impact, sometimes they survive and he can pick 'em up and re-use 'em. He runs across a flint stone, he picks it up, right?

AS IT TURNS OUT HOWEVER, not everything that looks like a flint stone IS a flint stone.

First step: #pray. Being burdened with a loadstone counts as a minor problem and your deity might uncurse it (which would let you drop it).

In this case, she didn't. Boogers.

So Tharg divested himself of ALL his rocks and a bunch of other loot he was carrying around for eventual BUC-testing and identification and tried to make it up to the safer levels of the dungeon.

Naturally, he ran across a trap door on the way.




Things got hairy on the level below. Swarmed from all sides by unpleasant monsters out to get him. That werejackal had a wand of Magic Missile and he was zapping Tharg with it over and over.

Then Tharg remembered the tales of his father's demise. How the power of ONE WORD could have saved him. Acting quickly, he stooped over and traced that word into the dust at his feet:



That's right. ENBereth! Begone, vile--

Wait, no, that's wrong.




Yes! ELBERETH! Run you fools! Run!

And so Tharg cowered on his Elbereth tile and time passed and Tharg healed up a bit. And then he ran into one of the new wrinkles of v3.6.1:



"Elbereth" is no longer eternal. Every time it causes a critter to flee, there's a small chance that one of the letters will fade. If you wait long enough, you are guaranteed to lose a letter or two. And once that happens, you're subject to attack again. And unless you're hitting the : key every turn, your first indication that you've lost Elbereth is when your HP starts going back down.

You can, of course, rewrite the word.




First off: That looks less like a nymph and more like a villain created by Todd McFarlane.

Secondly: Crap, a nymph. And me without any sling ammo to try and kill it from afar.




Elbereth only prevents melee attacks and spellcasting. It does not, for example, prevent the Kobold Shaman from throwing a potion of blindness at Tharg. Fortunately, he had eaten a Floating Eye corpse earlier, so it was less of a problem than it could've been. But now he has no way of knowing if his Elbereth is still working or not, and a much lower chance of writing it successfully if the old one fades.

Eventually, however, the blindness wore off. And eventually, Tharg gained back enough HP that he felt confident in taking on the monsters. One-by-one he overpowered them, and pried the Wand of Magic Missile out of the dead claws of the werejackal. Now the turns have tabled! Take that, Kobold Shaman!



Bah. Stupid werejackal, using up all my charges.

And then to add insult to injury, the nymph came back and stole Tharg's oilskin cloak. Something we'll have to worry about later, though. For right now, the priority is getting back up to the main dungeon area.




And here we are again, one big happy family. Now time to get out of here.
 
Top Bottom