• The Infractions Forum is available for public view. Please note that if you have been suspended you will need to open a private/incognito browser window to view it.

(Let's Play!) Slash'EM Extended, a NetHack fork

Bluescreenofdeath

Dev Team
Validated User
Astral elementals? You mean the ones with the ranged passive attack? Well, they don't retaliate if you melee them, but of course that means exposing yourself to their attacks... they're rather dangerous. And if you got one early in the mines, it was probably the result of a polymorph, which means fleeing or using Elbereth may be the only options.
 

Leeroy

Registered User
Validated User
It sounds like a good idea! ;)
I couldn't shoot them down really well as they are amorphous and my wand of cold left them unphased! :eek:
 

Bluescreenofdeath

Dev Team
Validated User
Oh, you tried to kill it with a wand of cold? That doesn't work, since they resist every element. Only weapon attacks and certain rare nonelemental spells (e.g. gravity beam) can hurt them.

Yeah, astral elementals are designed to be highly dangerous. They also possess every attack in the game, rolling randomly every turn to see which attack they will use against you.
 

Leeroy

Registered User
Validated User
Youre right! I wil search for the mana bolt spell series before going to Mine's end! ;)
 

Bluescreenofdeath

Dev Team
Validated User
Finally, Simon Belmont is back in the age-old SLEX 2.1.7 (currently I'm working on 2.4.4!) and this version needs to be purged from my hard drive so I can finally start a new game in the up-to-date version :D Anyway, we just failed to complete the Lawful Quest because of a bug, but the Chaos Quest is finished so we only need to find the neutral one now. So let's get out of the lawful quest.



Those jedi fools in the weird-looking room, they apparently can't turn their lightsabers off even when I'm far away so they end up wasting all the energy. Not that I need lightsabers anyway, I'm not sure if lightsaber forms even exist in this version of the game.

Since Simon Belmont is a necromancer :p, I use my command undead spell that is not at all overpowered to obtain a couple extra pets. Also, some annoying punishment trap on the way out tried to throw a wrench into my gears...



...but thankfully I can just dig pits and bury the ball in there. *Really* making my way downward now. I think we've seen level 27 for a moment, this time however we really need to brave it and the room filled with U-class monsters is gonna be really annoying. Especially since I can't use the pokedex now so I'm not able to see the stats of the randomized ones! Not even source diving can reveal their secrets since they're different each game.

We do have a large squad of pets at our disposal now: red_kangaroo the Elena's plateau boot (whom I'm riding), Elph the old psychic dragon, James Weatherby the spectre, Khyron the specter (different base monster even though it's pronounced the same as "spectre" :p), auspx the night lord and Tuxedo Mask the blood dragon. However, U traditionally means umber hulks, and they have confusion attacks. My fear is that a great deal of my pets will be killing each other in confusion, and not all of them are capable of leaving corpses for turn undead.



Or, you know, maybe we won't bother at all! They're still asleep, so as long as I don't make unnecessary noise I can just bypass their entire room with this stair!



Except... this isn't the next dungeon level. It's a useless one-level branch that would have the spider caves but they got replaced by a different level this time around. Sure looks a bit like a sokoban level, so chances are there's another bag of holding that we don't need. We will #annotate the level though in case I ever slip up and end up putting a wand of cancellation in mine.

Sigh. So we might end up having to traverse the terror hall after all. Oh wait, there's the real downstair, so we don't. Ha! Some umber hulk was indeed awake and had dug his way to this room already but I killed him and no pets got confused. Then I magic whistle all the pets to me and escape. Always keep in mind that if the magic whistle becomes cursed, it fails half of the time, and those failures will wake up monsters; mine is still uncursed, thankfully.



Can someone please tell me why riding a steed constantly scuffs engravings underneath you? It's like the steed can't ever stand still! Anyway, there was an unknown spellbook in this chest and since spellbooks can paralyze you when read, either due to being cursed or because they're out of charges, I always want to have an Elbereth engraving to make it more likely for me to survive in case I do get paralyzed. When you're all alone, i.e. without pets, and haven't cleared the place out yet, don't just go and read every unidentified spellbook in Orcustown without precautions. Characters have been ruined that way.

Anyway, the spellbook is knock, which is very useful indeed, I wish I'd had it earlier. Makes punishment a trivial matter of casting the spell at the chain, and we don't need to deal with keys breaking anymore either :D



Yay, brain golem corpse!

Dungeon level 29 seems to have quite a bunch of monsters, and our pokedex is also back so we see what they do, yay! But then I try to use knock on a container and that somehow causes me to dismount from red_kangaroo, argh... I do manage to re-saddle and mount him though. Also converted that Moloch altar to Osiris, resulting in a couple of demons being spawned which my pets will hopefully sort out.

Something must have untamed Khyron the specter though, because he's only peaceful now. I merrily offer troll corpses that seem to be coming from either a troll hall or a throne room, and then Tuxedo Mask puts on a pair of speed boots and "seems to be moving much faster" but trying to displace him gives "Tuxedo Mask Weeper doesn't seem to move!" Dude, how long does it take to put on a pair of boots? :p



Noooooooooooooooooooooooooooo :(

Oh well, no more sacfesting on this level :( But I did get a four-leaf clover from this sacrifice. Then I re-unite with Khyron in the treasure zoo and cast command undead successfully.

The room with the downstairs is full of traps, including a spell loss trap that I thankfully discovered without triggering it. But now somehow one of my pets got confused, auspx and Khyron are fighting each other. Is there a confusing monster around?



How fitting. Also, something else that is confusing ;): yellow branch staircases. They were recolored to pink because yellow was looking too similar to white, but this is an old version... Let's find out where this one leads, shall we?

You hear the roar of the sea. That can't be right.... It's the Sunless Sea! And it wasn't replaced by a random level, so we can theoretically get a magic lamp here! First we need to remove a couple giant crabs that happen to be on the shore, and then I try to read a curare-impregnated spellbook but some smartass monster reads a scroll of summon undead. Oh well, thanks for the free pets I say! :D



Teleportitis moved me to open water though. There are devilfishes and femme fatales and other really dangerous sea monsters here...

GAAAAAAH! This is the second time that I clearly saw an undead monster and trying to move into it to attack gave me "Wait, there's a hidden bla bla bla you just wasted a turn"! Goddammit! Why is that? Undead monsters are always visible to me, I shouldn't be getting this message! At least I do manage to kill the ribbon fishes in the end, but still...



Spoiled myself so I'd actually find it. Apparently my in/extrinsics allow me to pick up items from the water, which is very welcome. Then I make my way back and ommmmmmg cracking this amulet trove proves to be a very solid decision:



Man, this is awesome! Guardian Angle is an artifact amulet of life saving that grants prism reflection! I can swap out my shield of reflection for something better, e.g. a second weapon now because Simon Belmont could really benefit from some extra attack power! Now I really want to read that spellbook though, using my pets to keep me safe.
 
Last edited:

Bluescreenofdeath

Dev Team
Validated User


HRRRRRRGH! Tuxedo Mask drained that fire metroid at least half a dozen times so he should have run out of hit points several times over, but he didn't die and managed to read a damn scroll of flooding, summoning eels and stuff all over! Will I ever manage to successfully read this spellbook?



Hmm. A level 8 attack spell that fires superpoisonous gas. Despite having maxed attack spell skill it's still at 37% fail, so I'd need to train it quite a bit to get that to 0%, but on the other hand having a heavy hitter (for 40 mana per shot) wouldn't be so bad... except that it's a poison-element spell, and poison resistance is very common among monsters. On the bright side, most of my undead pets will also resist it, making it relatively safe to cast even with pets around, unlike, uhh, FIREBALL for example which would burn my undead pets to cinders :D

So I switch back to dual-wielding, but my weapon choices are all so poor... decided on a +0 silver spear for now, although I'll be looking for something better. Main weapon is still the stake of course. The next level also shows quite some undead; let's see what else lies in wait for us here.

Wisdom went up from training! Yay! This improves our casting chances for toxic to 28%, and also some other difficult spells are less difficult now. Blessed be that +6 ring of gain wisdom, without it Simon's spellcasting would be a lot worse.



Whaaaaaat? He got killed by a wimpy shark??? And now he's gone for good because there's no corpse? Damn. Ah well, he wasn't my strongest pet anyway. We also seem to have a rarity room on this level, filled with 7 and X and possibly some other "rare" monster classes, which actually prove to be quite annoying... but I fire up the toxic spell and it works alright :)

Found that room, and it also had a cloaked xorn that can cause map amnesia so I wanted to kill it quickly but it escaped via a shaft... We'll run into him on the way down. For now there's a speedhack horror though, which has a depression engulf attack among other things. He doesn't resist poison though, and you know what that means...



Feels good to have a heavy hitter, even if many monsters will resist! It certainly does more damage than the "regular" elemental spells, like fireball or magic missile. A silver dragon suddenly appears but sadly doesn't drop scales, and icky things keep coming from god knows where but they're no big deal by this point. My bulbous ring is +2 but doesn't autoidentify when worn, so it might be increase accuracy or damage; could become useful once my natural wisdom score gets high enough to render the +6 ring superfluous.

You entered a mysterious hamlet! You fly down along the stairs. Level 31, and it's a special level! Subzero also fell through the shaft but he's here, so no worries there. Anyway, Level 31. Castle of the Winds-inspired, of course, it's mainly farmland everywhere with a few additional quirks. Let's explore this new area of the game that we've not seen in the Let's Play series yet!



Hahaha LOL good thing I decided to search :p This trap would, if I were to trigger it, send me back all the way to dungeon level 1, and remove itself in the process. Obviously it cannot be used while you have the Amulet of Yendor, because that would be incredibly unbalanced. Still, this can be a problem because I can't easily get back to the levels above now; would need to either level teleport or walk all the way back from 1 to 31.

Anyway, farmland. Not sure if we've seen it yet. Since Simon can fly, he can just move over it freely; grounded characters would have to either repeatedly use #force on the farmland in the hopes of removing it, or possibly cast fire spells at it to burn it down. Let me demonstrate it:



In this version, it seems that burning any burnable terrain (e.g. farmland or grass) will always, without fail, transform it into ash terrain, and if that gets burned again it becomes lava, so this is actually a very dangerous thing to do. Speaking of which, the hamlet proper has grassland everywhere, and a highway as well as some burning wagons and poisoned wells. Also the occasional statue trap, but there's no sign of Gunnhild's general store or the blacksmith's forge... hmm...



Here we'd expect to find the shrine to Odin, which isn't there either. Welp, it looks like Hrungnir has been through this place already while we were busy searching for that scrap of parchment in the Gnomish Mines, and wondering about the fell creatures that were encamped therein. It seems that the Hill Giant Lord has carried out Surtur's orders, which commanded him to stop at nothing until the threat has been removed, and WE are that threat. He got lucky we weren't there, because we'd have killed him and ordered our pet ghosts to sing the dirge (DIRGE! :D), that's for sure!

But, unlike the actual Castle of the Winds, it seems that the map continues to the east. After all, there's the semicolon so something must be over there. In Castle of the Winds you'd neither be able to fly nor dig out walls, but this is NetHack where those actions are possible.



Look, we found a mountain range! Since we're riding, mountains are easily passable terrain for us; for a non-mounted hero they're almost impassable, even when flying (but passwall would still allow us to move through them freely). Doesn't seem to hold anything of value, though. What's this room to the east? Let's check that out.



Ahh, that's clever! The shopkeeper seems to have retreated to this secluded place and barricaded himself in there! So chances are Hrungnir didn't catch him after all! With my knock spell I unlock the door and find Luna's general store; she seems to have a relatively poor selection of goods and only offers a useless appraisal service, but the important part is that there's a branch staircase in there.

Now there's a problem though: we can't get in. Simon is invisible so Luna will forever be blocking the door, even if I were to dismount and put the pick-axe away. What do we do?



The answer is simple: we teleport. Now we'd be able to browse Luna's wares and fight the bunch of mimics that's certainly in there :D, but more importantly we can go look whether that branch is something important. Maybe it's the secret underground passage to Bjarnarhaven that allows us to... okay I stop already :p Castle of the Winds was my entire childhood and young adulthood though, I played the game to death and beyond. I didn't know what a "roguelike" was back then, but I did know that I thoroughly enjoyed it. And now, with SLASH'EM Extended, I'm able to recreate that old experience but with the big difference that I'm the dev team now, so I can make the game exactly like I want it to be, and it's great!

Also, happy boxing day everyone (and belated Merry Christmas)! ♥ :)
 

Bluescreenofdeath

Dev Team
Validated User
Simon Belmont is back again, and will check out the branch on dungeon level 31 now!



The Giant Caverns - and it looks like they're real! Yay! Like most special levels, this one also doesn't appear in every game, and I think it never appeared in the Let's Play yet. But this time it actually did, and that means we get to play it. Obviously there's a lot of giants here, and if I had a tinning kit I'd try to eat them all, but somehow Simon didn't find one in almost 40k turns...

So I need to compete with red_kangaroo who is trying to eat them as well. Sadly, version 2.1.7 doesn't have the directive technique yet, with which a sufficiently skilled player could control whether the pet can eat food off the floor, but there's stuff I can do to make it easier. Such as having the pet eat a troll corpse and then run to where the giant corpse is so I can pick it up and eat it from my inventory.



Except, I still seem to have the nasty trap effect that prevents me from seeing my satiation level. Of course I answer "y" (in NetHack 3.6.0 it's so devious that the wording of the question was changed to "Continue eating?", which kills players who operate on muscle memory), but damn I want to eat this corpse! It's still 1575 units of nutrition too, so I'd definitely choke if I tried to force it, and that would likely result in me losing my awesome artifact amulet of life saving. Recent versions made it possible to find artifacts multiple times but this is not such a version so it would be lost forever.

Ah, but I have a cloak of magical breathing, and this is the time to use it!



There's still plenty of giants that all want to be eaten by me.

An adventurer wraith shows up, so I use ubercommandundead on it to add it to my team. Which might actually be a bad idea because his darkness attack will constantly make areas unlit... guess I won't be taking him out of this branch. And then we encounter the boss of the level!



He just has a 3d10 melee attack and no other specialties, but of course he reads a scroll of root password detection so now he could be anywhere. Then I trigger a summon undead trap and cast command undead some more times so I have even more pets! We're not taking all of them back:



Having too many pets makes them difficult to handle anyway. Still, command undead is ridiculously overpowered. It takes a while to get the entire team downstairs because the stair is in the northeast corner and there's not enough space for the pets to warp to, but then we're on dungeon level 32 where our journey continues.

Oh look, a weapon shop offers us the enchant weapon service.



If Simon was incredibly rich, he could enchant his stake to +8 now, but of course he's not.

We have both a living room and a dragon lair on this level; some of my pets buy the farm here. In particular, disintegration-breathing dragons aren't very useful for pets' survivability, even if the dragons only aim them at me; at least some of the undead pets are resistant though. In the living room I find a fire trap that finally allows me to improve my searching skill to skilled, yay!



There is an old black dragon, which by definition needs to die. I dismount in such a way that I end up on the corpse and eat it, but don't get the resistance :( At least the "Satiated" display is back though, so apparently that trap timed out at last!

Somebody whispers about food rations, so chances are this level has a magic portal to Sam's Black Market. Found it but it's not the actual black market; there's a random level with paved roads instead. It has an undead hyper doll that would make a decent pet since it's rather fast, but they deal low damage so I decide it's not worth it.



Hmm. A chaotic artifact that grants +5 to-hit, +6 damage, fire resistance, warning and stealth, and also acts as a luckstone when wielded. And all the effects of the stake should be in effect when it's in the second hand while dual-wielding, so... I guess we found an improvement over the +0 silver spear we've been dual-wielding so far :) Sure, it's gonna cost a bunch of skill points to master the sling, and Simon just barely has enough skill points left to do so, but he'll get 14 more skill points from leveling up so this should be no problem.

By wasting a couple holy waters on my saved stack of cursed enchant weapon scrolls, I turn the sling from +0 to +6 and we're good to go. Simon doesn't have regular ammo though. Gonna make some by smashing statues! Except that somehow none are to be found anywhere, and I can't go back up above level 31 due to the back to start trap...



This special level would be a temple to Moloch, but the RNG decided to replace it too. Simon actually has no business playing on this one but I hang around a little anyway in the hopes of getting some rocks. Killed a migo queen but eating her corpse didn't increase my intelligence.



Aww, such a cuddly Magdalena ♥ But we defeat her and then it's on to the next level!

There's a grape jelly, which immediately gives me a flashback to my stupidest death in the game EVER. Man, Alexei was supposed to ascend, really! Oh well, too late now. I easily clear out a 42 room and then we're on level 36, where James Weatherby polymorphs into a hurog due to a trap. Careful. I don't want to trigger this trap, because while I might be resistant due to the stake, my steed probably is not, and there's always the danger of shuddering.



Another shop! Maybe magic whistling my pets in there will allow them to steal some stuff!

Kahran042 seems to cancel them all, or at least he constantly chuckles when attacking the mimics in melee. But then I suddenly turn into a werewolf!!! What the hell? I must have become infected at some point... Good thing it's still possible to get at the contents of my containers in wolf form; I fail once but then I got the sprig of wolfsbane and eat it. Also, I'm just so glad werewolves don't break their armor upon polymorphing. Now I'm a drow again and quickly re-equip everything.

My potion store heist doesn't go that well, the pets keep stealing potions of oil and then I get an unknown one that engrave-tests as cyanide so I need to cast restore ability a couple times to get my strength back. Then apparently a couple of my pets have fallen into a trap door because they're on the next level down:



Then I trigger a trap and start turning to stone! But thankfully I have lizard corpses to fix this; gotta see if I still have a wand of speed monster with which to zap myself.

You hear a nearby zap.



And suddenly we're in Gehennom! Something zapped Simon with a wand of banishment, and it was outside of his magic lamp range so he didn't even see what it was, meaning the wand didn't get identified; he was on level 82 for a second but is on 76 now. Banishment can be a game-ender if it happens early, however Simon has several scrolls of teleportation, including some cursed ones, and a ring of teleport control so he could easily get out if he wanted, at the expense of a scroll. Or several, if the RNG decides to be an ass and gives me the "You shudder for a moment." effect.

Will Simon teleport back to safety, and if he does, will he give the area where that banisher is a wide berth so to not get banished again? Or will he take his chances with the demons in Gehennom? If there are readers, they may give their input now to decide what Simon Belmont's fate will be! Anyway, tune in next time! ;)

Happy New Year 2019 everyone!
 

Bluescreenofdeath

Dev Team
Validated User
Here's a little teaser for the next version:



My redguard priestess in BIGslex (125x41-sized dungeon levels) has so much sanity that monsters constantly look like random other monsters, similar to hallucinating. There's several swamps on this level, and they're hellishly dangerous. Of course I could shoot the sea monsters down with my +4 crossbow at expert skill (high enough to occasionally fire 2 bolts per turn!), but that feels like a waste... I'd much rather just find the downstair and get out of here.
 
Top Bottom