(Let's Play!) Slash'EM Extended, a NetHack fork

Leeroy

Registered User
Validated User
Well, I already found a bug...
It seems that invisible pets (in my case Rulindil) stay invisible regardless of the see invisible intrinsic...
 

Bluescreenofdeath

Dev Team
Validated User
Not a bug; there's the in/extrinsic split in this new version, which will probably take some getting used to. Basically, all properties will now have stronger effects if you have both the intrinsic and the extrinsic version of it. In the case of see invisible, having only one or the other means that you see some invisible monsters but not all of them.

But something else is definitely a bug... and it has just ended my promising bigslex priest run on the server. A koplich on the large graveyard cast burden, creating a loadstone in my inventory. Normally this wouldn't be a big deal, my carry capacity was 3000 or so and a loadstone weighs 1200. Worst case I'd have been burdened until I use a holy water or remove curse. But due to a bug, the loadstone's weight was actually 21600. So I became a sitting duck, and with no means of uncursing that stone in my open inventory, I had no choice but to stand there and wait until I die. I'll have to fix that soon, because as it is right now, that effect can randomly end the game...
 

Leeroy

Registered User
Validated User
That's interesting to know! ;)
My thalmor run is getting promising again! :)
I even got a +10 silver long sword!
The demons are going to be a real breeze! :LOL:

EDIT:
I got killed again...
I'm trying a Jedi and I found a decent stack of shuriken! ;)
 
Last edited:

Bluescreenofdeath

Dev Team
Validated User
Yeah I saw that and was surprised! Apparently there's not many other DNHslex players :( But I'm wondering, you got so far and then got killed while fainted from lack of food, how could that happen? At that point you surely had the 200 (slight exaggeration) food rations from Sokoban, which should have been enough to last for the entire remaining game...
Well, better luck next time! :)
 

Bluescreenofdeath

Dev Team
Validated User
Simon Belmont is back in Gehennom level 76 and finally found the inspiration to continue his quest! He's still playing the age-old version 2.17 even though the development version is at 2.47 already - when his adventure finally ends, it'll be like playing a completely different game for the next char... ;)

Anyway, Simon got banished. Without his pets, so those that aren't inediate might go feral over time. Of course Simon could simply try to levelport back but that's boring... so I'll instead go ahead and explore a bit. He finished his quest anyway and his next official assignment would be to find the yellow staircase, which would be a pink staircase in newer versions, to Sheol! Maybe he can find it!



This level also has part of the real Wizard's Tower, because it's now always on level 75-77. So that means next level up from here is where Rodney lurks, whom I hopefully won't wake up too soon.

It seems that the local monster population is posing no problems to Simon here, the first thing that actually impedes his progress happens to be a trap:



But I simply dig out the square south of it. A super nupesell nix area is capable of preventing the player from walking on it, which can be devastating if there's no way to dig around it, but here it's not much of an issue.

I take out a draugr mummy that would actually be rather dangerous if it got lucky with its stealing attacks, and then there's an uber pwnzor. Those are also really difficult, but since they're undead I try to command undead him... which only turns him peaceful, for some reason?! Ah well, at least I don't have to fight him now! Finally found the upstair after searching most of the level, and...



A *high* priestess??? Those aren't normally generated. This must be some sort of special level. There's also a star vampire nearby, which is NOT undead for some reason, and my radar shows a bunch of various actual undead too. This could be dangerous.

Of course the priest hussy tries to cast paralyze at me, and if I weren't magic resistant that could well be the end of me, but I resist and start battering her with my two weapons. Also, Moloch tries several times to zap me with lightning which does nothing either.



Wtf, how did that lich manage to zap his wand of lightning at me vertically when he's horizontally adjacent? Anyway, I kill him and grab the wand for myself. Now all the bats and assorted other monsters are milling around to the east but in order to get to them, I first need to find a secret door, and then I open up with my sling. Managed to kill some priest of Moloch but another takes his place immediately, and it turns out that one of my stacks of rocks is cursed! So I switch to melee and kill several such priests, apparently they made their home in this area or something. Oh well, at least I'll have some altars for BUC testing available.

Somehow the other lich also had a wand of lightning. This might be non-random, actually. There also happens to be a very annoying trap cluster and the walls are nondiggable so I have to wade through, and probably repeatedly whenever I'm passing through this level, but I persevere and now the next hordes are coming!



The purple h is a mind flayer that I absolutely want to eat.

Look at all those priests of Moloch though:



Yes, the white @ are all priests, some of them even high priests!

Now I have a problem though, because an undead camperstriker named Tillbull appeared and threw a couple gray stones into my inventory. And when I wanted to shoot him with my sling, the rocks flew to the west even though I tried to shoot to the north. Trying to melee him ended up with me moving west, too, which means those stones are counterclockwise spin stones. It's not really possible to show the effect of that in pictures, but it means all my directional input is shifted 90 degrees counterclockwise - if I try to move north I'll walk west, if I try to walk west the char will go south and so on. Until I can get that stone uncursed, I'll have to be careful.



Oh come on kindly stay in your stinking temples you bastards! I'm trying to regenerate enough mana so I can spam-cast remove curse until the stones are uncursed!

Ah well, this hussy woman is now dead too, although there's many more where that came from. Then I kill another such priest and eat his corpse, and my next attempt to cast remove curse gets through so the stones are uncursed now. I won't just drop them anywhere though, that would be a classic mistake. No, either I dump them in some container or drop them in the water. In any case I don't want monsters with weapon attacks to get them.



Instakilled that vampire bat! Ha! And there's a reason for which I have to mention that yes, this also happens while dual-wielding because why the hell not? :p Why would a wooden stake mysteriously lose its ability to act like a wooden stake just because I have some irrelevant weapon in my other hand is beyond me. No, here in slex the instakill chance still triggers.

There was another high priestess, who is also dead now. They're dropping large quantites of spellbooks too. So many spellbooks, in fact, that it's basically impossible to keep all the spells memorized... but hey, one of them was extra healing!!! At last, Simon has a HP-restoring spell available! This is very welcome and will be cast a whole lot, that's for sure.



I can't mention the unidentified appearance of that spellbook here. :p But heeeeey, Simon can fire death rays at enemies now! Hopefully I'll have enough mana to repeatedly cast them!

An ECM archer amnesiac appears and I try to tame him, but he gets frenzied instead. Oh well. So I kill him. Then it's on to the east and the fire traps are REALLY annoying me now, but I blast open the double drawbridges and start battling the deeper ones, but there's also nightgaunts and they tickle red_kangaroo. Annoyingly, when your steed is frozen, you also can't attack in melee for some reason unless you dismount, but I decide to spin up my finger of death spell for practice.



That serves the kakuna right for using its slowing gaze on me! Arrgh!

Now the devilfish is closing in though, and breathes disintegration at me which my amulet thankfully reflects. Then I make a stand, and the devilfish breathes fire before it dies. There's another devilfish in the blue room to the east though.

Huh, for some reason a whole lot of deeper and deepest ones are milling around the water to the south. This can indicate some treasure on the bottom of the sea, and anyway I really don't feel like fighting them all anyway so I'll just ignore them unless they get too close to me. Alright, the other devilfish is also dead now and I go up to level 73:



Rooms and corridors for a change! But the problem is that the level is apparently filled end to end with monsters. We're gonna be having tons of battles here, that's for sure.

There was a lava grue which I really didn't want to tangle with in melee, so I used finger of death and probably got him. And then a boss monster shows up:



But the bigger threat is a level 34 incanting spirit, who is a spirit that (surprise!) incants terribly. Also, some invisible monster stole my scrolls of cure and is nowhere to be found now, gah. Anyway it's annoying to be fighting so many grues so I decide to use my stack of 400+ darts because I still don't have enough ammo to use my sling.

Something summoned "undead", one of which was actually a death brigadier, i.e. a demon, and that then gated in a porn incubus! Since I definitely don't want to get undressed now, I vaporize the incubus first.

Johanetta eats 5 uncursed +0 darts named Shot Series {0}! Oh, so there was a second boss here after all. And since she's also a grue-class monster, she likewise has that annoying 50% displacement in melee. She then proceeds to teleport away via scroll, just like Ann Kathrin also did earlier. Cowards. Hopefully those scrolls weren't cursed!

Now of course there's also a commanding spirit that commands terribly, which means command me to go away (via teleporting gaze), which I don't want to happen. Also, a poison grue drops a very useful wand of entrapping that will come in handy on the vibrating square level if I make it that far.

Yes! Killed the commanding spirit without being teleported away! But look at those undead trying to path their way to me:



Maybe I should try to command some of them?

Noooooo! Some invisible thieving monster stole red_kangaroo's saddle! Hopefully he can squash it, it might in fact be the monster that stole my scrolls of cure earlier.

YES! Got it! No idea what the monster was but it's dead now and I recovered all my stuff! Then there's a huge wraith, which seems like a potentially useful pet so I cast command undead and it works on the first try, so he's called ArkisVir now. Also found a throne that wants me to sit on it.



Yeah, like I want to wade through those undead player monsters now. Now I could advance riding to skilled, but... why bother? This old version doesn't have skill-unlocked techniques and I have so few surplus skill slots that I want to rather save them now.

Except, I seem to have to battle most of the undead anyway because they can just go around to the west and appear where I am. Oh well. I kill some and make it to the next upstair so I whistle ArkisVir to me and now we're on level 72. This is a demon lair, and it has a whole lot of ghouls and ghasts for some reason? Who could be the resident demon lord?



Yeenoghu! I thought he was the prince of gnolls, so there should actually be lots of gnolls here... or maybe they're there too, and he just so happens to also have an army of undead for some reason? Anyway, there's one thing you should not do when fighting Yeenoghu, and that is wasting all your mana casting magic missile at him. Because he's immune to those. Cold works very well on him, but I'll just try to hack him up in melee.

Your steed doesn't respond! Gah, he got off a paralysis attack against red_kangaroo! Oh well, I'll just throw darts... except that he somehow hits fairly hard, battering me with his flail and causing confusion... anyway Yeenoghu eventually tries root password detection but it fails, and now he seems to have warped to the upstair so I slaughter some of the resident gnolls.



Good job, ArkisVir! Freely suck away all of that exploding thing's levels!



Yeenoghu you lamer! Come back and fight!

Bah, no idea where he went, he might have used the upstair but I can't see him there. Also, level 71 is a special level:



It looks like Simon will have to brave the version from before the fixes, which means there's simply a gargantuan army of monsters here and it'll take forever to chew through them. I'm gonna attempt that some other time. For now, I'm calling it a night. Simon Belmont has explored five levels of Gehennom so far and still has plenty of more levels to search for the Vlad downstair, so stay tuned...
 
Last edited:

Bluescreenofdeath

Dev Team
Validated User
Just a little newsflash: I'm not dead and will continue this LP someday, but real life (work, especially late shifts even though I'm actually an early bird... groan...) and working on the next version of SLEX are eating up way too much time. I'll have 2 weeks of vacation in balconia come April, though, and then I can hopefully play some more :)

On the bright side, I managed to finally compile DNHslex for Windows! It's probably hellishly bugged but at least it's there at all, and the binary is here. Now everyone can play DNHslex both online and offline! Maybe I'll even do another DNHslex playthrough with this new binary, because it means I'm no longer restricted to playing on the server ;)
 

Leeroy

Registered User
Validated User
Yeah I saw that and was surprised! Apparently there's not many other DNHslex players :( But I'm wondering, you got so far and then got killed while fainted from lack of food, how could that happen? At that point you surely had the 200 (slight exaggeration) food rations from Sokoban, which should have been enough to last for the entire remaining game...
Well, better luck next time! :)
I mishandled my inventory again as far as I remember, so I must have accidentaly left my food rations on the top of Sokoban, under the effects of a nasty trap!
 

Bluescreenofdeath

Dev Team
Validated User
It's time to finally continue the undead slayer run! Now that I have vacation, I got a lot of free time - *the* opportunity to play SLEX again! Even if I actually have zero desire to play an age-old version of the game, but this undead slayer is probably ascendable so I have to try anyway...

First things first, I decide to ditch the sling because I don't have a good supply of rocks anyway. Instead, I switch back to Rattleclinker as my offhand weapon. And now it's a matter of grinding through what seems like endless hordes of monsters. Let's get started!



Lately I've been playing on the server so much that now I'm unused to the absence of lag ;) Anyway, there seems to be some boss monster and also an arbitrator, who will constantly use a whistle to wake up everything on this level. The boss also soon appears to the south: Schrumpel, a level 10 demon boss. First I have to take care of an elemental lich but then I kill Schrumpel and somehow he reappears to the north?! Did he spawn twice? I sure hope I don't have the respawn trap effect...

So I kill him again and also a speedlich but then Schrumpel reappears a third time to the south! Damn it, why are there so many of him? There's also arch-trolls and other covetous enemies and a fourth instance of Schrumpel, and this time the damn bastard tags me with an inertia attack, blah.



Uhh... they're kicking my ass for some reason. Time to quaff the potion of full healing, even if it feels like a waste. I quickly ready another from my box, and try to command undead the vorkolak but of course it doesn't work, so red_kangaroo ends up killing it.

Several arch-trolls and afrits are trying to gang up on me and of course command undead fails again and wait what -



NOOOOOOOOOOOOOOOOOOOOOOOOOOOooooooooooooooooooooooooooooooooo...

ARRRRGH! Red_kangaroo was extremely important for my general strategy! He was making me fast while riding, had a lot of resistances, dealt great damage in melee etc. RIP, he didn't leave a corpse either so now he's gone for good. Well, at least it's not as bad as the bullshit that happened to my dissident on the server; his mount got erased by the game because it crashed on me during switching dungeon levels, and now that save doesn't even load anymore. I have a core dump of that crash but technical difficulties prevented me from running it through gdb, I hope I can do that soon. Anyway, Simon Belmont's mount wasn't erased by a game crash, but killed by a wand of cold, and now these undead are trying to lock me up in here. There's also several arch-troll corpses that want to revive themselves, which will cause additional trouble.



Yeah sure, get frenzied you annoying afrit, as long as the other one is tamed so I can displace it and get away from the troll! Still, blaaaaah! I want my steed back!

And of course the tame afrit decides to be ultra annoying by moving north, and some covetous demon-or-other warps to that tile before I get another turn. Graaaaah. I squash it (it's a spiked devil) but the frenzied afrit very quickly takes me down to critical health again. Frenzied monsters are no joke, and afrits can deal 128 damage per turn!



That was a complete waste of a wand charge. I narrowly remove the wight that ported to the north and try to run from the afrit but now a cat lich warped to me! There's just way too many damn covetous monsters on this level...



Noooooooooo! I'll never get out of here!

By the way, this is after me using the second potion of full healing. I have another, but it's in my chest and taking it out may well result in me dying to the afrit. What I'd need to do here, is to confuse myself somehow and read a scroll of teleportation to escape from this level because this is frankly unplayable, but that would also take several turns...



Uhh yeah. I think I just ensured this character's death by trying to cast a forgotten spell. It gave me the freeze status effect instead of confusion.

You die... But wait... Your medallion begins to glow! Sigh, there goes the amulet of life saving. I immediately unihorn the freeze and dim away but they still bring me down to 35 HP again before I get the next turn. And I only have a wand of extra healing with an unknown amount of charges in my inventory, as well as a stack of scrolls of healing. The wand doesn't heal very much and may also be out of charges, so I can only use scrolls of healing now. Hopefully Simon's HP will go up, for if the scroll heals less than the damage output of these monsters it's game over.



Unfortunately it turns out that the afrit is faster than me though, and he catches up to me and I die. Do you want your possessions identified? DYWYPI? Reached #14 on the local highscore list, and the dumplog is here: https://pastebin.com/raw/73NFCV3s. Yeah, I probably wasn't playing very well and a Tariru would have gotten out of that situation, but I also lacked any means of teleporting the monsters away (wand or spell of teleport) and of course the level was no-teleport for the player, so once I was surrounded by all those monsters there wasn't much I could do. And I didn't get lucky with the attempt to confuse myself. Should have gotten out a potion of booze or whatever...

Ah well! Game over! I type "exit" in gdb which somehow always causes a BEX error (the actual command is "quit"), but since this post is so short, I'll add something else for the viewers' pleasure:



Llllllllllllladies and gentlemen, welcome tooooooooooooo... DNETHACK SLEX! :D Since I've managed to get a binary that works on Windows XP at last, we can play now without me having to do so on the server! It was an unholy pain in the butt to get it to work and there's certainly a bunch of bugs but hopefully none of them will be gamebreaking ;)

That time is long past. The ascendance and immortality
of the gods proved a lie, for heaven now lies in ruins,
trampled into the bloody soil of earth by the cursed
mind flayers.


You, a newly trained Survivor, have been trained
from birth as the instrument of hope in a dying world.
One day soon, when your sister, the Last Oracle Sara,
deems you ready and the Army of the Bastion has
completed its secret preparations, you shall-


*ALERT: Picket line reports contact. Hostile entities
vectoring on Last Bastion. Picket line engaging targets*


<<Tanja, report to ritual grounds at once. We must complete
the ritual before the courtyard is overrun>>


And somehow there's a --More--, as if all that drivel wasn't enough:

**EMERGENCY ALERT: Picket line overrun. Telemetry
suggests 100% losses. Hostile entitites vectoring
on Last Bastion.**


<<Once the ritual is complete, proceed to the Dungeons
of Doom. I will contact you at that time-place with
further instructions>>


And then there's yet another --More-- for one single line that says <<Good luck, sister.>> and we're finally in the game. Meet Tanja the Anachrononononononononononaut:



Yes Demo, in case you're reading this Let's Play thread (and I will bundlebundlebundle you into reading it :D), my anachrononononaut can be lawful ;) I really preferred it when they were called "anachronist", because I can actually pronounce that word, whereas with the anachrononononononaut it's impossible to remember how many "no"'s are there! Anyway, the game tells us that we can Ctrl-W (which would normally be wishing in wizard mode) to use a ward, and annoyingly it also means you can no longer Ctrl-W to wish in wizard mode and have to type #wish instead, but I've never felt any need to use any wards in dnethack...



Hey look! We have future tech weapons! And unlike their SLEX counterparts of the same name, I have no idea how they're used! This is gonna be fun. Apparently the blasters can shoot ammo and the ammo isn't an item for some reason, and I guess the power packs can be used to recharge them but there are only so many power packs and then I'll run out; on the IRC I often heard talk about how you should haul ass to the quest as an anachrononononononaut to gear up, because there's apparently more future tech there. But how to survive up to that point? I mean, if I manage to shoot everything with my blaster before it can reach me I might just be able to make it, but... Ah well! Let's just play the game and die to something stupid! :p



For some strange reason, Tanja can see 3 squares in the dark. I guess that's useful. Helps me avoid ambushes! But I get ambushed anyway because after pushing a boulder around, a pack of jackals jumps at me. I try my best to kill those vicious beasts and surprisingly manage to pull it off, but trying to eat the corpse that dropped fails because the plasteel helm covers my whole face. So I take it off and hit e but the corpse doesn't come up as an option? Pick it up, try to eat it... You cannot eat that! Argh, I can see how this is going to be a problem. Anachronononononos can only eat processed food, or so it seems, and I have 12 "protein pills" (probably Orwellian newspeak for the pabulum that everyone is forced to eat in whatever future the anachrononononono story is referring to) which I could eat but again, eventually I will run out and then? Starve? Because if I try to use #pray I get this:



Why is the game trying to tell me that I don't pray to that god anyway? The game is not my dad, I can pray to whoever I want :p Anyway, with the inability to eat corpses or pray for food, the food clock is much tighter, which is probably the main reason why you have to beeline to the quest. Or Boroban, where there's such an overabundance of food rations (which I *hope* I'll be able to eat) that they may well last for the entire game anyway. So I guess that's our target. Make it to Boroban and secure a food source. Let's see if Tanja survives for that long, since she also doesn't have a pet and therefore has to handle all monsters by herself, and Elbereth doesn't exist because we have that ward system instead and Tanja starts the game knowing no wards.



Not wanting to put up with the absymal odds of finding the secret door that has to be somewhere (and wasting dozens of nutrition points in the process), I #teleport with this conveniently placed teleport trap (magic resistance prevents me from just triggering it normally). Now there are a couple grid bugs and a stack of candles, I wonder whether candles will even make me see farther in corridors?

The rabbit bites! The rabbit is suddenly very cold! The rabbit dies! Apart from the fact that I'm wondering "the rabbit bites... what? well, thin air? like, WHAT is the thing that he's biting?", this is the yuki-onna's special passive cold attack that deals damage to things that attack us in melee. I'm not sure if it scales, but it's pretty good. On the downside, yuki-onnas certainly have some restrictions but I don't yet know what they are. Maybe they don't regenerate when wearing iron or something. I wouldn't be surprised if that was indeed the case.

Anyway, I find a buckler, which is a shield unique to dnethack apparently and whose german name is "Beschutzer" (weil er einen vor dem Gegner beschutzt :D), and I wear-test it and it's +0, but it only gives one additional point of AC. Since Tanja started with -4, she now has -5 which is actually extremely good this early in the game.

Somehow there's no goddamn downstair to be found on this level though, even though this is dungeon level one!



That large unexplored space to the south of me is certainly capable of having another room, but I can't teleport and who knows where the RNG placed the secret door? Let's bet that I won't find it before I get hungry?
 
Last edited:

Bluescreenofdeath

Dev Team
Validated User


Due to a bug, tile highlighting does not work at all on the Windows version, which means that I had to actually step on the food ration to find out there's a downstair here. But hey, I found some food! Yay! And now I'm on dungeon level 2, where I continue to battle newts that take 5 hits to kill and only give 1 XP. Compared to SLEX, leveling up is painfully slow here, at least early on. On dlvl3 I find a potion and make the mistake to dip it in a force pike, which of course causes it to form a coating because every other potion does that in dnethack, but without telling you in advance what the coating will be so you can only call it "bubbly coating" and then, when you see in your inventory that you now have a "envenomed force pike", you may be able to deduce what it actually was. Blah. Anyway, "envenomed" means I most certainly wouldn't want to quaff that potion anyway.

Yay, managed to level up by firing my blaster at a rot worm! It fires "scarlet bolts" for some reason, even though the discoveries screen says that scarlet bolts are heavy blaster bolts so I have no idea why it didn't say "the heavy blaster bolt hits the rot worm" but whatever. As I explore on this level, I "hear a ceiling tile fall"... oh my.



Yeah, dnethack added creepy level sounds to levels that have dilapidated armories. They then also got added to slex, but I made them deliberately rare; here they're probably rather common. I fire my blaster at the rust monster and of course the bolt misses but then it explodes for some reason, and blasts the wall apart?! So the brown pudding is dead now because it was caught in the explosion, but the rust monster lives and eats a scale mail, well I wouldn't have wanted to use that anyway. Fire!



The *door*??? Uhh... there is no door! There's a wall behind the rust monster! (Also, of course the bolt missed again!) Anyway, the explosion hits the rust monster but it survives and is attacking me in melee now, which shouldn't matter anyway because my stuff can't rust. Well, maybe the buckler can. So I kite the rust monster over some spear to make it lose turns to eat it, and shoot it again; finally the bolt hits and the rust monster is dead now while Tanja reaches experience level 4. Now the blaster has 85 ammo left.

You are now wearing a wide helm. You feel itchy. Argh, I was right. Yuki-onnas get downsides from wearing iron, or whatever material that thing is made of (sadly this isn't SLEX, so there's no way to see the item materials in-game). Shame, it's a +2 helm! I'd have -7 AC and be able to eat normally! Well, you know what? I kick a wall to lose a few HP and then see whether I can still regenerate. Turns out that I do. Buhbye plasteel helm! Hello wide helm! :D



So that 3-tile light extends to unlit rooms too, I was wondering whether that would be the case. Yuki-onnas seem rather powerful and the itchy iron effect doesn't do all that much ;) Then I find a piece of cloth that is pink for some reason, but it can't be a cloak of magic resistance since we started with one.

Argh, stupid me thought it would be a good idea to shoot a floating eye because I forgot I can't eat it anyway! Ah well, at least I can no longer accidentally bump into it, which would be a technical instadeath. And there is no warning if you walk down a dark corridor and a **** of a floating eye suddenly decides to be on the next tile; you either play super cautiously, or every step you take can be the last. Then I run into some "trällerträllerträller" newt zombies; I can't stop calling them that even though due to the lack of a highlighting option they're not actually highlighted green here :D Anyway they're very hard to kill and while bashing them with my blaster I get hungry of course. So I eat the food ration. And then I run into something really annoying:



Water. Without the paranoid liquid patch. That said, there is no paranoid trap patch in dnethack either, so you need to be forever careful, and items can obscure traps so you might trigger them anyway! Ack! I see a tripe ration but that's not really worth going for, what I need is food rations. Kill a gecko and find a magic whistle, then shoot a leprechaun... Welcome to experience level 5. You feel itchier. Huh? Itchier than before? But I can still regenerate HP :) Dungeon level 5 now, and the enemy power starts creeping up quite quickly but my blaster kills two coyotes in one shot but I also discover a big downside: if I shoot something at point blank, I get hit by the explosion and that HURTS LIKE HELL.



Just soooo very glad I have this passive cold attack. Still, it would be nice to, you know, have a melee weapon! Not sure how the pike is supposed to work but it also has charges so my guess would be that it eventually runs out...

On dlvl6 I run into a centaur who also readily kills himself with my cold attack. And there's more of that goddamn water, arrgh. Then a quickling on 7 that likewise kills itself and it drops a potion which is of course object detection:



The shop over there has an upgrade kit and a stiletto! And the latter is a melee weapon that I can get to skilled! Well, it would still suck since it's only a knife, but certainly better than bashing with a blaster... so let's make our way there and see if we can afford it. Killing an Anja's sneaker and a wallaby puts me to XL7 and I feel quick but also itchier yet again, really wondering whether my regeneration will eventually become zero? And of course there's water again and a rope golem! Chances are that if my blaster bolts miss the golem, they will hit the shop door and then I'll have an angry shopkeeper which results in a quick YASD.



Yay it wasn't cursed! But it only cost 3 zorkmids, so it's probably +0. Akalapi also had a scroll of identify, because price identification exists in this variant (and all other variants that aren't slex for that matter). Using a small mimic from the shop for target practice, I reach basic knife skill and then advance to dlvl8.

Wow, managed to not only read a spellbook of sleep (which was warded with a circle of acheron) but it's even at 60% fail, i.e. less than 100%! And taking off the helm further improves it to 33%! Sleep is a really important spell so I switch back to the plasteel helm, causing me to feel relieved, and a chest happens to have an engraving underneath that reads "Army of Yendor armory annex. Trespassers will be shot." It also has a dart trap and the "cold-iron sears my flesh", argh! Taking extra damage from silver is bad enough if you're e.g. a vampire, but extra damage from iron is hell because almost every regular weapon is made from iron! Anyway, I simply pick up the chest and don't even get burdened from it because hehehe :p, and I force it with my stiletto. This chest has quite some equipment and also a few wands.



I don't know whether those things will have random enchantments, but probably yes, so I'll wait for an altar (hopefully anachronononononos can BUC-test that way!) before trying on anything. One of the wands gives no message while the other should be polymorph.



Seems that I missed the boroban upstair earlier. Sokoban in dnethack is "exactly like vanilla", except with some differences and because of those differences I'm calling it boroban; I decide to call it a day here though, and we'll continue some other time. Also, wow, a dnethack character that survives an update!
 
Last edited:
Top Bottom